Bug report #2855

Bundled Qt translations

Added by Volker Fröhlich almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12915

Description

Is there a need to bundle the Qt-translations?


Related issues

Related to QGIS Application - Bug report #11668: Qt: not all languages show (qt) translated button captions Closed 2014-11-17

Associated revisions

Revision dd182b64
Added by Jürgen Fischer over 9 years ago

remove Qt translations (fix #2855)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 9e9f7884
Added by Jürgen Fischer over 9 years ago

remove Qt translations (fix #2855)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Paolo Cavallini over 9 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I think so. Closing it for now, please reopen it if necessary.

#2 Updated by Volker Fröhlich over 9 years ago

  • Resolution deleted (invalid)
  • Status changed from Closed to Feedback

It's not advisable to include Qt translations in applications. They also don't introduce a new language.

If the Qt translation has a problem, that should be mended upstream. The translation is also version-specific.

I simply deleted the Qt translations for the Fedora packages and couldn't witness any problem. I also don't think you need them for Windows, since they should be part of the installed Qt-Package.

#3 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Qt translation removed in .

Also available in: Atom PDF