Bug report #2809

Python throws error messages when QGIS will be closed during plugin manager is checking new plugins

Added by Horst Düster over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12869

Description

During startup of QGIS the plugin manager looks for plugin updates and new plugins in the connected repositories. When you close QGIS during these manager checks you get the following error message:

".qgis/python/plugins/plugin_installer/installer_data.py", line 173, in stateChanged
TypeError: 'NoneType' object is not callable

History

#1 Updated by Borys Jurgiel over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2775; fixed in b6256d02 (SVN r13743)

Also available in: Atom PDF