Bug report #2805

List of recently used coord systems is growing

Added by aperi2007 - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12865

Description

Opening the Project Properties,
and going to Coordinate reference Systems.
In the recente used I can see one (or two) coord systms.
If a change to the "General" section and after I return to the Coordinate suystems seciton I can notice the recentrly used are become twice (4 for exemle).
I repeat and the recently became siz, and so on :)

History

#1 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

yes, you see the last four coordinate systems in the list (or less if you have used less than 4).

#2 Updated by aperi2007 - about 10 years ago

Yes, but the list after 3 click (3 change of windows) report

wgs 84,
epsg3003
wgs84
epsg3003
wgs84
epsg3003
wgs84
epsg 3003.

every time I change the windows beetween "general" and "coordinate reference system" , without choosing a specific srs, it growing.

So perhaps the real problem is that the list is growing because the srs listed are not unique.

Replying to [comment:1 jef]:

yes, you see the last four coordinate systems in the list (or less if you have used less than 4).

#3 Updated by Jürgen Fischer about 10 years ago

Replying to [comment:2 aperi2007]:

So perhaps the real problem is that the list is growing because the srs listed are not unique.

Or there's something wrong with your srs.db or qgis.db. That could also explain your WMS problem #2797.

#4 Updated by aperi2007 - about 10 years ago

I try to remove the
qgis.db from .qgis directory.
Restarting qgis the qgis.db was recreate but the problem is again here :(

Now I try to re-install all. To see if the prblem was here.

Replying to [comment:3 jef]:

Replying to [comment:2 aperi2007]:

So perhaps the real problem is that the list is growing because the srs listed are not unique.

Or there's something wrong with your srs.db or qgis.db. That could also explain your WMS problem #2797.

Also available in: Atom PDF