Bug report #2797

Change EPSG for a WMS Layer

Added by aperi2007 - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12857

Description

Adding a wms layer.
Try-ing to change from default wgs84 to the needed epsg:3003.
The dialog for change the coordinate system seem don't find the 3003 ID.

Instead it work try-ing to change EPSG for a shapefile.

wms_search_epsg.jpg - screenshot of search epsg:3003 (72.2 KB) aperi2007 -, 2010-06-10 10:24 AM

History

#1 Updated by Jürgen Fischer over 10 years ago

is the WMS server you're trying to use public? Does it offer EPSG:3003?

#2 Updated by Giovanni Manghi over 10 years ago

Replying to [comment:4 jef]:

Does it offer EPSG:3003?

exactly, this is a server configuration, the client has nothing to do with that

#3 Updated by aperi2007 - over 10 years ago

Replying to [comment:4 jef]:

is the WMS server you're trying to use public? Does it offer EPSG:3003?

Yes I use it from many months.
It work always, and always I was able to change from 4396 to 3003.

The string I use is this:
http://web.rete.toscana.it/sgrwms/com.rt.wms.RTmap?servicename=_rt_wms&version=1.1.0&SRS=EPSG:3003

It work.

But int the qgis-windows "Add a WMS layer"
qgis ask me to change the Coordinate Reference System.
I do it always and always it find epsg:3003.
Now It don't find epsg:3003 (a projected coordinate system).

#4 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:7 aperi2007]:

#5 Updated by Giovanni Manghi over 10 years ago

works for me too

#6 Updated by aperi2007 - over 10 years ago

If I search for a unexistent epsg-id I have a clear error "no matching projection found".
But if a search for 3003 I don't have a "not found" error.
Simply it return nothing but in the list of found it is not reported.
There is only and always the wgs84.

#7 Updated by Giovanni Manghi over 10 years ago

Just to be sure I tested also under win 7 and it still works for me.

#8 Updated by aperi2007 - over 10 years ago

I tried to re-install completely qgis, also removing settings from windows registry.
But the bug is still here.

#9 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:13 aperi2007]:

I tried to re-install completely qgis, also removing settings from windows registry.
But the bug is still here.

Are you able to reproduce this on a different machine? Or anyone else?

#10 Updated by aperi2007 - over 10 years ago

Yes I testeed it even on another machine always on windows.
It is here.

I discovered hovewer that it happened only when using the parameter:
..&version=1.1.0&..

If I use the parameter
..&version=1.1.1&..
or
..&version=1.1.3&..

it don't happened and the srs (epsg:3003) is search with success.

Replying to [comment:14 jef]:

Replying to [comment:13 aperi2007]:

I tried to re-install completely qgis, also removing settings from windows registry.
But the bug is still here.

Are you able to reproduce this on a different machine? Or anyone else?

#11 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Replying to [comment:15 aperi2007]:

Yes I tested it even on another machine always on windows.
It is here.

I discovered however that it happened only when using the parameter:
..&version=1.1.0&..

Oh, I didn't realize that you are specifing the version and/or SRS manually? There's no need to. QGIS adds the selected SRS and the VERSION advertised in GetCapabilities to GetMap requests anyway. So adding it again might irritated the server.

Also available in: Atom PDF