Bug report #279

Low resolution of point symbols in print composer / printed map

Added by wolfgang-qual-gmx-net - about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10338

Description

Resolution of point symbols in both print composer and printed map is quite low (qgis 0.8, preview 2)
Wolfgang Qual (wolfgang.qual-at-gmx.net)

print_composer_symbols_resolution.png - low res point symbols in print composer (70.7 KB) neteler-itc-it -, 2006-12-22 05:41 AM

qgis.png (54.9 KB) lami-faunalia-it -, 2007-01-03 08:58 AM

History

#1 Updated by neteler-itc-it - over 13 years ago

Hi,

the low resolution of the point symbols is (for us) really a problem. I assume that somehow the selected resolution (in my example 300dpi) isn't applied to the point symbols. And/or too much anti-aliasing is used or JPEG compression.

Best,
Markus

#2 Updated by lami-faunalia-it - over 13 years ago

The problem is not only for point symbol but also for same elemnts of map scale and legend. See the image attached

#3 Updated by Tim Sutton over 13 years ago

Moved to milestone 0.8.2 since we wont be fixing any further issues before the 0.8.1 release

#4 Updated by Steven Bell - about 13 years ago

This problem occurs because QGIS is using the same point symbol it does for the map canvas, but scaling it up. If your symbol is the default circle, the symbol will be ~7 pixels tall, regardless of the composition resolution.
Fixing this will probably require the addition of an extra function to get the point symbol as a variable or high-resolution pixmap.

#5 Updated by leo-lami - about 13 years ago

If you set the symbol scale in the map composer from 0.5 (default) to 0.1 the point semm to be well draw but in the problem occours ever in the legend.

#6 Updated by Tim Sutton about 12 years ago

Reassigned to Marco since he is refactoring the map composer

#7 Updated by Marco Hugentobler about 12 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Resolution of point symbols should be ok now.

#8 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF