Bug report #2750

Context menu appears after digitizing a feature

Added by Andreas Neumann over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12810

Description

After digitizing a line or polygon feature the digitizing of one feature is finished with a right-click.

Unfortunately, the context menu with the toolbar choice appears after this right-click when it should not. This is a major annoyance and interrupts an otherwise smooth digitizing process.

Somehow the event of the right click shouldn't be forwarded to the underlying window that trigger the context-menu display - at least during the digitizing process.

This should be fixed before a 1.5 release. Thank you!

History

#1 Updated by Jürgen Fischer over 11 years ago

That's Windows only, isn't it?

#2 Updated by Andreas Neumann over 11 years ago

you may be right - problem doesn't appear on OSX. Still have to test Linux after rebooting.

#3 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2239

Also available in: Atom PDF