Bug report #2239

Right menu shows up after right-clicked to complete polygon feature

Added by Maxim Dubinin almost 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12299

Description

Weird behaviour, rather annoying and confirmed at least on 3 other machines. Hard to reproduce though.

- Create new layer
- Capture new polygon
- Right click to complete
- Attrib window show up. Hit ok
- Polygon completed but right click window also shows up where right click happened.

This is not a problem if attribute window is suppressed through settings. I guess the problem is somewhere around emitting signals or smth like that.

Screenshot-1.png (76.3 KB) Giovanni Manghi, 2009-12-10 01:16 PM

Associated revisions

Revision d325df0d
Added by Jürgen Fischer almost 11 years ago

fix #2239

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 2ba2faf9
Added by Jürgen Fischer almost 11 years ago

fix #2239

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by dr - almost 11 years ago

confirmed

#2 Updated by Giovanni Manghi almost 11 years ago

Didn't made to reproduce under linux but under windows was pretty easy. See attached image.

#3 Updated by Jürgen Fischer almost 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

should be fixed in 2ba2faf9 (SVN r12607).

#4 Updated by dr - almost 11 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

problem still not fixed

#5 Updated by Andreas Neumann over 10 years ago

I can confirm that this problem only exists on Windows XP. Not on OSX and Linux (Ubuntu).

Nevertheless I think it is very important to fix it before shipping 1.5.

I have set it to "Must Fix for Release". I also set Priority to "Major" since it is really annoying if you really digitize more than a handful of features.

#6 Updated by Andreas Neumann over 10 years ago

Paolo and others,

Please do not postpone this to 1.6. I think it is absolutely annoying if you digitize a features and get the context menu whenever you finish an element.

Besides, it leaves a bad impression on new and existing windows users.

You wouldn't like your web browser to display the context menu whenever you click on an element (link, etc.), would you?

Thank you for revisiting this bug.

Andreas

#7 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Replying to [comment:7 neumann]:

Thank you for revisiting this bug.

As you insist: 3970b786 (SVN r13733) has an ugly workaround, but it work for me now.

Also available in: Atom PDF