Bug report #2726

Mapserver plugin does not export 'labelitem' property for layer with labels

Added by Richard Duivenvoorde over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12786

Description

Using the mapserver export plugin, a layer which has labels does not find a 'LABELITEM' line in it's mapfile anymore. This worked in older versions, but is apparently broken in current version.

It looks like it has something to do with a change in the project-file format.

Currently a 'maplayer'-element has 3 'label'-elements, the plugin code is broken because of this.

labelitemfix.txt Magnifier - patch for issue (1.79 KB) Richard Duivenvoorde, 2010-05-17 01:29 PM

History

#1 Updated by Richard Duivenvoorde over 11 years ago

can somebody do a simple review?

I think I can do the checkin myself.

#2 Updated by Paolo Cavallini over 11 years ago

Is this fixed?

#3 Updated by Richard Duivenvoorde over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

yep, fixed in ac2526b1 (SVN r13709)

Also available in: Atom PDF