Bug report #2718

selecting too large symbol size takes ages to display

Added by Paolo Cavallini about 10 years ago. Updated about 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12778

Description

If a too large symbol size is selected (e.g. 2000), QGIS freezes for several minutes

History

#1 Updated by Paolo Cavallini over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Seems solved now

#2 Updated by Paolo Cavallini over 9 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

Confirmed with current trunk, both on 32 and 64 bit. Raising the priority, as the system can become so slow to be unusable, and the user may be forced to reboot, thus losing data.

#3 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Paolo Cavallini about 8 years ago

  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Paolo Cavallini over 6 years ago

  • Status changed from Feedback to Open
  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)

#7 Updated by Anita Graser about 6 years ago

Just tested in master now and the problem seems to be gone.

#8 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Feedback
  • Target version deleted (Version 2.0.0)
  • Operating System deleted (All)
  • Status info deleted (0)

#9 Updated by Paolo Cavallini about 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF