Bug report #2688

crash when opening an unsupported raster layer

Added by Borys Jurgiel over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:ersts -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12748

Description

When I accidentaly try to add a raster file not supported by GDAL (e.g. something nonsensical like a mp3), qgis crashes with the error:

Error: GDAL Error 4: @/home/borys/foo.mp3' not recognised as a supported file format.
Segmentation fault

Looks like a trivial test is needed.

History

#1 Updated by Jürgen Fischer over 10 years ago

I can add unsupported file formats with 735f9e03 (SVN r13413) just fine.
Ok, I also get the error message, but it doesn't crash.

#2 Updated by Borys Jurgiel over 10 years ago

ok, I'll debug it farther

#3 Updated by Giovanni Manghi over 10 years ago

I can replicate this under linux.

Open a GRASS raster and export it with the module r.out.ascii

Then try to add it to QGIS, under linux it will crashes with

GDAL Error 4: @/home/gio/Desktop/teste1' not recognised as a supported file format.

under windows it will show only

"is not a supported raster data source" 

#4 Updated by Giovanni Manghi over 10 years ago

The crash happens (under linux) also when I try to open a mrsid raster in a installation where I have not enabled mrsid support.

#5 Updated by Giovanni Manghi over 10 years ago

mails about my last two comments have not been sent by the system, so I'll bump this ticket.

#6 Updated by Paolo Cavallini over 10 years ago

Slightly different, but it could be the same: #2768

#7 Updated by Jürgen Fischer over 10 years ago

Still not reproducable. Which GDAL version is in use where it the crashes?

#8 Updated by Borys Jurgiel over 10 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Now it works again with gdal 1.7, the problems were with 1.6. I'm closing the ticket as it seems to be related to gdal only.

#9 Updated by Borys Jurgiel over 10 years ago

Btw. Lutra, if you can confirm the crash with gdal 1.7, please reopen.

#10 Updated by Giovanni Manghi over 10 years ago

a quick test with Ubuntu 10.04 and qgis trunk and now it seems that does not crash anymore.

#11 Updated by Paolo Cavallini over 10 years ago

Confirmed, the bug is still there, both with GDAL 1.6 and 1.7

Error:
GDAL Error 4: @/home/paolo/Desktop/2010.ods' not recognised as a supported file format.

During startup - Warning message:
��
Segmentation fault

Also available in: Atom PDF