Bug report #2649

editing postgis attriubte table crashs qgis when some fields are hidden

Added by cmoe - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12709

Description

Editing the attribute table of an postgis layer with hidden fields leads to a crash when toggling back the editing mode.

1. Add a postgis layer to qgis
2. Open the layer properties
3. Go to the attributes and set for some fields the edit widget to 'hidden'
4. Open the attribute table
5. Enable editing and do some changes
6. Disable editing
7. Qgis crashes

The message in the terminal window is: Fatal: ASSERT failure in QList<T>::operator[]: "index out of range", file /usr/local/qt-4.5.2/include/QtCore/qlist.h, line 399

Reloading the same postgis layer shows, that the changes are saved, its only qgis that crashes ....

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

probably fixed 58acc85c (SVN r13311) - although the crash wasn't reproducable here.

#2 Updated by cmoe - over 10 years ago

Hi jef

Thank you for the fix, it works for me now.

Also available in: Atom PDF