Bug report #2640

Problems with New Labelling plugin

Added by mesajs - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12700

Description

New labelling works well on the map canvas, but rendering in print composer is poor:

1.Label placement is too low.

2.Fonts not properly rendered.

Attached examples are snips showing roughly the same section of a map tagged as follows:

AROUND - Labels around points, or above line and below line selected for lines

OVER - Labels over points, or on lines

CANVAS - as appears on the main map canvas

COMPOSER - created in map composer with map saved as a PNG image

For example, in composer_around.jpg, the label Deer fence (lower left hand corner) is on the line, while labels Fence A and Fence B are well below their lines. Points Tl48 and Tl61 (to the left of label Upper wetlands) are so far below their associated points that Tl48 appears to be associated more closely with point Tl61. Label Tl61 looks like T61. The equivalent snippet from the main QGIS screen (canvas_around.jpg) shows none of these deficiencies.

Using QGIS r13288 under Windows Vista 64.
Font is Ms Shell Dlg 2, font size 8. The label engine is set to Show all labels.

PS Sample composer_screen_around_jpg shows how the section from composer_around.jpg appears on the screen before saving as a png image. It's virtually unreadable.

canvas_around.JPG - Map canvas - labels around points/lines (35.4 KB) mesajs -, 2010-04-09 01:57 AM

canvas_over.JPG - Map canvas - labels over points/lines (29 KB) mesajs -, 2010-04-09 01:57 AM

composer_around.JPG - Composer - labels around points/lines (62.4 KB) mesajs -, 2010-04-09 01:58 AM

composer_over.JPG - Composer - labels over points/lines (30.9 KB) mesajs -, 2010-04-09 01:59 AM

composer_screen_around.JPG - Composer as seen on screen (15.1 KB) mesajs -, 2010-04-09 02:00 AM

History

#1 Updated by Marco Hugentobler over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Labeling support in print composer should be fixed in recent build. Note that this does not include true 'wysiwyg' in the composer map on screen (because many methods work on mm units).

But the output (to paper or file) should be good now. Please reopen if you think it is not the case

#2 Updated by luca76 - over 11 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

I tested latest Windows SVN build. It still doesn't work, see the bug #2796

#3 Updated by Martin Dobias over 11 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Let's keep this bug closed since the reported problem has been solved.

Also available in: Atom PDF