Bug report #2796

Labelling plugin: wrong printing result

Added by luca76 - over 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12856

Description

Steps to reproduce:

1. Enable labelling plugin
1. Apply labels to a line vector layer
1. Make sure you set labels as curved
1. Try to print it with "Arial" font and 7 points in height

Results are different: printed label are too narrow and distorted, on the screen they are OK

See the attachements.

qgis-screen.JPG - QGIS screenshot (160 KB) luca76 -, 2010-06-09 07:22 AM

qgis-print.JPG - PDF generated from QGIS (300 dpi) (119 KB) luca76 -, 2010-06-09 07:23 AM

qgis-screen-newplugin.JPG - Using new plugin (179 KB) luca76 -, 2010-06-09 11:02 PM

qgis-composer-newplugin.JPG - Composer screen (no options touched, all default one) with new plugin (197 KB) luca76 -, 2010-06-09 11:03 PM

qgis-pdf-newplugin.JPG - Resulting PDF (horrible :-( ) (134 KB) luca76 -, 2010-06-09 11:03 PM

History

#1 Updated by luca76 - over 10 years ago

It seems that the labels doesn't respect the distance between letters.

#2 Updated by Martin Dobias over 10 years ago

The labeling plugin has been moved to qgis application and its functionality is available from the "attributes" toolbar (the one with attribute table and measure tools) and from Layer menu.

If you still see labeling plugin in your plugin manager, that's just a remainder from the older install. You can delete it as it is outdated.

I can't replicate your problem, I believe it's happening to you only because you're using the old plugin. Please test again.

#3 Updated by luca76 - over 10 years ago

I've disabled the labeling plugin.

Made a new project, loaded vector layer, applied curved labeling.

Same result. See attachment.

#4 Updated by luca76 - over 10 years ago

NOTE: I'm using the OSGEO4W qgis-dev package, yesterday's version.

#5 Updated by Borys Jurgiel over 10 years ago

I confirm the same problem on Ubuntu 9.10. If affects printouts, pdfs (rasterized and not), svg and raster images.

#6 Updated by jekhor - over 9 years ago

This bug seems fixed for me.

#7 Updated by luca76 - over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

this bug is now fixed.

Thank you!

Also available in: Atom PDF