Bug report #2613

Check geometry validity returns non OGC compliant result

Added by dr - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12673

Description

If try to check such polygon: "with Check geometry validity tool, it returns "Feature contains an unnested hole, but such type of polygon is OGC compliant. I find this type of polygon in PostGIS manual: [http://postgis.refractions.net/docs/ch04.html#OGC_Validity] (pic. (i)), it's valid.

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2613

#2 Updated by Jürgen Fischer over 11 years ago

Replying to [comment:1 jef]:

duplicate of #2613

oops, #2612 that is.

Also available in: Atom PDF