Bug report #2612

Check geometry validity returns non OGC compliant result

Added by dr - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12672

Description

If try to check such polygon: "with Check geometry validity tool, it returns "Feature contains an unnested hole, but such type of polygon is OGC compliant. I find this type of polygon in PostGIS manual: [http://postgis.refractions.net/docs/ch04.html#OGC_Validity] (pic. (i)), it's valid.

History

#1 Updated by dr - over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

#2 Updated by Jürgen Fischer over 11 years ago

  • Resolution deleted (duplicate)
  • Status changed from Closed to Feedback

#3 Updated by Jürgen Fischer over 11 years ago

  • Status changed from Feedback to Open

#4 Updated by Jürgen Fischer over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

bad TRAC day. duplicate of #2611

Also available in: Atom PDF