Bug report #2610

Printing with SVG symbols: QGIS ignores totally the size of SVG symbol

Added by luca76 - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12670

Description

Steps to reproduce:

1. load a point layer;
1. assign a SVG symbol to it with a size defined;
1. try to print to PDF

result: QGIS ignores totally the defined size

print_composer_screenshot.png - screenshot of the QGIS "New Print Composer" (82 KB) michele zanolli, 2010-03-31 05:14 AM

export_as_image.png (54 KB) michele zanolli, 2010-03-31 05:22 AM

History

#1 Updated by luca76 - over 11 years ago

change the 2. step with this:

2. assign a SVG symbol to it with a size based by map-unit

#2 Updated by michele zanolli over 11 years ago

As you can see in the attachments only the red labels (numbers) are correctly scaled. The other symbols and the label of the line are wrong.

#3 Updated by Alex Mandel over 11 years ago

I agree this should be tackled but I don't think this should hold up a new release if not solved.

#4 Updated by Martin Dobias over 11 years ago

Umm, I'm unable to replicate.

Is that new symbology or old symbology or both?

Does that happen only with SVG symbols with size in map units or also in other combinations? (simple marker / font marker, millimeters)

Does the problem exists in PDF export, in raster export - or in both? It seems that trapanator refers to PDF export, while zanollim refers to raster export.

Martin

#5 Updated by michele zanolli over 11 years ago

Martin,

Because I need rotation of the symbols by a layer attribute, currently I am using the old symbology.

Yes, the problem occurs:

with SVG symbols

with size in map units (and not in pixel)

in PDF export and raster export

#6 Updated by Giovanni Manghi over 11 years ago

Because I need rotation of the symbols by a layer attribute, currently I am using the old symbology.

this is already available in new symbology

#7 Updated by luca76 - over 11 years ago

Replying to [comment:6 lutra]:

Because I need rotation of the symbols by a layer attribute, currently I am using the old symbology.

this is already available in new symbology

yes, but only for unique value symbology. For categorized and graduated values, the option doesn't exists.

#8 Updated by Marco Hugentobler over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed for old symbology in

Also available in: Atom PDF