Bug report #2591

QGIS uses wrong WMS version

Added by joto - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12651

Description

QGIS 1.4.0 sends no VERSION for WMS GetCapabilities. When it gets version 1.1.1 capabilities back, it still does the GetMap with VERSION=1.3.0. This breaks servers that don't work with 1.3.0.

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1984

#2 Updated by Jürgen Fischer over 11 years ago

  • Resolution deleted (duplicate)
  • Status changed from Closed to Feedback

oops, not a duplicate after all. Do you have a public server where that happens?

#3 Updated by Jürgen Fischer over 11 years ago

Not reproducable with neither 1.4 nor trunk.

#4 Updated by joto - over 11 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Sorry, my fault. QGIS isn't the problem. Mapserver is. It returns a WMS 1.3.0 GetCapabilities. I thought I configured it not to, but it seems that doesn't work.

Also available in: Atom PDF