Bug report #1984

QGIS Doesn't send VERSION parameter on WMS getCapabilities request

Added by guillaume - about 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:12044

Description

Hi,
Althought not mandatory in WMS specs, the VERSION parameter has become important since most WMS servers now offer WMS 1.3.0. Using Qgis against Mapnik WMS service, the getCapabilities sent back by Mapnik is 1.3.0 by default (when not requesting a specific version) and Qgis is not able to parse it properly (no WMS_Capabilities or WMT_MS_Capabilities found).

So I think Qgis should send VERSION=1.1.0 as long as it can't handle WMS 1.3.0 specs properly.

Regards

Guillaume

History

#1 Updated by Marco Hugentobler almost 11 years ago

Is there a public available test server instance of mapnik running? Please provide an URL.

QGIS WMS client is supposed to work with 1.3 servers (e.g. QGIS mapserver). Probably the capabilities response from mapnik look a bit different, so it would be good to have a mapnik instance to debug and adapt the QGIS source accordingly.

#2 Updated by Marco Hugentobler over 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

no user feedback for some time, so closing ticket.

Also available in: Atom PDF