Bug report #2578

GUI for several GRASS modules wrong

Added by Paolo Cavallini over 10 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:12638

Description

The GUI for several GRASS modules is wrong: in the qgm file instead of option is chosen, therefore a browse button appears, which has no meaning in this context.

Examples of affected modules are: r.patch, v.patch, r.series, g.region.multiple.raster, g.region.multiple.vector

This is due to the apparent impossibility to concatenate more than one layer in commands. Adding support to this would possibly solve also the v.to.db problem with multiple concatenated columns. See also #1627

module-input-multiple.png - Multiple input widget (36.9 KB) Radim Blazek, 2015-12-15 08:03 AM

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Pull Request or Patch supplied set to No
  • Assignee deleted (Lorenzo Masini)

#3 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Radim Blazek almost 5 years ago

Multiple map input is supported since 2.12.

#7 Updated by Radim Blazek almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF