Bug report #2391

Layer properties dialog and Unique Value: cannot see which bitmap is used

Added by luca76 - almost 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12451

Description

If you have a point layer and you use Unique value with different bitmap, you cannot see which bitmap is used to each value (in the "Point Symbol" list area).

qgis-symbol-1.JPG (186 KB) luca76 -, 2010-06-28 05:19 AM

qgis-symbol-2.JPG (187 KB) luca76 -, 2010-06-28 05:19 AM

History

#1 Updated by Giovanni Manghi almost 11 years ago

(If I get it right) I cannot replicate the problem under linux/qgis trunk. Can you explain the issue in a more detailed way?

#2 Updated by Paolo Cavallini over 10 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Closing it because of missing user feedback. Please reopen it if necessary.

#3 Updated by luca76 - over 10 years ago

  • Resolution deleted (worksforme)
  • Status changed from Closed to Feedback

Sorry for my late response.

It still doesn't work in latest trunk:

1. load a point shapefile
1. open the layer properties and open symbology (use the old symbology)
1. select "Unique values"
1. get two values and assign different symbol to them

close the dialog box and reopen the layer properties. When you select the two values on the list, the corresponding symbol on "Point Symbol" box is not selected.

For me it is a usability bug, you can fix it in 1.6.0 if you want.

See the attachments.

#4 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Feedback to Open

#5 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:5 trapanator]:

Sorry for my late response.

It still doesn't work in latest trunk:

Works fine for me.

#6 Updated by luca76 - over 10 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

strange... you are right.

It does work with a new project, using an old imported from 1.4.0 does not...

closing this bug.

Also available in: Atom PDF