Bug report #2336

loading a project from the command line results in broken rendering

Added by Ricardo Silva almost 11 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12396

Description

When calling qgis from the command-line with:

qgis --project path_to_project

The project gets loaded but the map canvas gets rendered incorrectly.

I am attaching two screenshots, one with the correct rendering and the one when I call qgis from the terminal with the --project flag.

Please note the incorrectly placed scale bar, north arrow and copyright info on the mapcanvas. Also please note that the map canvas seems to think its size is much smaller than reality. Also, on the vector layer that is rendered, only one point is visible, whereas the layer has more points.

correctRender.png - This screenshot shows the rendering as the project is loaded via the qgis GUI (105 KB) Ricardo Silva, 2010-01-01 10:41 AM

incorrectRender.png - This screenshot shows the rendering as the project is loaded via the command-line (106 KB) Ricardo Silva, 2010-01-01 10:42 AM

History

#1 Updated by Ricardo Silva almost 11 years ago

It seems that this issue is related to the state of the qgis main window. I am usually working with qgis's window maximized. Now I noticed that if I load the project from the command-line and then hit the unmaximize button, the window gets shorter (as expected) and also the rendering is back to normal. If I then go back to a maximized window everything works fine. I think the project gets loaded before the window is maximized, and that causes the rendering to become messed up.

#2 Updated by Paolo Cavallini over 10 years ago

Still true for a recent QGIS?

#3 Updated by Ricardo Silva over 10 years ago

yes, it still happens. Just tested it with QGIS 1.5.0-Trunk (rev. 13498) and the result is exactly the same as before. As noted in one of my previous comments, if I unmaximize the window and the remaximize it things get back to normal.

#4 Updated by Anne Ghisla over 9 years ago

I can notice a slight change in scale when I follow these steps:

1- Open QGIS maximised, load a layer, save the project as it is

2- Reopen the project, unmaximise the window, when asked if to save the project, say no

3- Reopen the project, so that QGIS will remember last window size (unmaximised) while the project was saved full with the maximised window.

It is a small changement, not as big as the attached screenshot show, even if i change window size and proportions a lot. If you can share the point data and the project that causes the problem, I'll try to reproduce the bug.

#5 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#6 Updated by Paolo Cavallini over 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#7 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#8 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#9 Updated by Médéric RIBREUX almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Pull Request or Patch supplied set to No

Hello, bug triage...

I can't reproduce this anymore with QGIS 2.13 master using whatever decoration (north arrow/copyright/scale bar) and whatever data (points/polygons). There is also no problem with the size of the main QGIS window and the loading of the project from the command line.

I am closing this bug...

Also available in: Atom PDF