Bug report #2330

Loading missing layer (shapefile) requires changing the "Files of type" setting

Added by John Tull almost 11 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12390

Description

When a project is opened and a missing layer is recognized, at least for shapefiles, the layer id is appended to the file name, so a matching file cannot be selected. E.g., the file being searched for in the dialog will be "File of type: Site_Areas.shp|layerid=0" whereas the file name is actually "Site_Areas.shp". The appended layer information seems to be masking the file in the open file dialog requiring the user to switch to all shapefiles in order to make the file selectable.

History

#1 Updated by Paolo Cavallini over 10 years ago

Still true?

#2 Updated by John Tull over 10 years ago

This is still a problem. I tried for a better title also.

The open file dialog populates the "Files of type" field with something like "my_shapefile.shp|layerid=0". Instead, it should only have the "my_shapefile.shp" without the layerid information. As a consequence, you have to change the "files of type" field every time you encounter a missing shapefile warning.

#3 Updated by Volker Fröhlich almost 10 years ago

Looks fine on Linux with 1.6.

#4 Updated by Paolo Cavallini almost 10 years ago

jctull, can you please test and close it if appropriate?

#5 Updated by John Tull almost 10 years ago

This problem persists in the current trunk.

#6 Updated by John Tull over 9 years ago

Still an issue in trunk.

#7 Updated by Maxim Dubinin over 9 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

seems like this is not an issue anymore with new missing layers dialog

tested under WinXP, f42443c9 (SVN r15701)

please reopen if necessary

Also available in: Atom PDF