Bug report #2317

Identify tool breaks work flow when no feature selected

Added by barryrowlingson - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Unix Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12377

Description

If you use the identify tool and miss a feature, the "identify results" window disappears and a modal dialog 'no features at this position found' pops up. The user then has to go click the 'ok' on that before doing anything else.

[ It's even more of an annoyance because the OK dialog always appears top-left of my screen - I suspect its not parented properly. There's a few dialogs do this ]

Wouldn't it be better for the "identify results" window itself to show a message "No features found at this position". One less modal dialog is a good thing...

Associated revisions

Revision e49d300d
Added by Jürgen Fischer over 9 years ago

fix #2317

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 9a766a7f
Added by Jürgen Fischer over 9 years ago

fix #2317

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 9a766a7f (SVN r12593). the message now appears in the status bar.

Also available in: Atom PDF