Bug report #2302

render caching places map in wrong place when re-enabling

Added by Steven Mizuno almost 10 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12362

Description

simple steps to reproduce with new project:

1. caching ON

2. load map layer

3. caching OFF

4. pan map a noticeable amount

5. caching ON

-- the map is drawn at its original location (when loaded) AND reading the cursor location is wrong since the map extents set by the panning haven't changed.

6. caching OFF

-- now the map is drawn at the previously panned location and reading the cursor location is correct.

I believe the cached map should be invalidated (dump the cache) when caching is turned off, hence the map will be totally re-drawn when caching is enabled.

History

#1 Updated by Giovanni Manghi over 9 years ago

confirmed with under Ubuntu linux.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Giovanni Manghi about 5 years ago

  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)
  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

In qgis master this does not happen anymore.

Also available in: Atom PDF