Bug report #2283

node tool/select features tool do not have effects on a shapefile

Added by Giovanni Manghi almost 11 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:12343

Description

I stepped into a shapefile (lines) that when toggled for editing doesn't react to the node tool or the select features tool. The same vector once imported and then exported trough GRASS seems to behave normally.

Link to shapefile:

http://www.faunalia.pt/downloads/shape_test.tar.gz

tested on qgis trunk under linux.

History

#1 Updated by Paolo Cavallini about 10 years ago

So probably the shapefile has topological errors. Not sure how should we deal with buggy shp, though.

#2 Updated by Maxim Dubinin over 9 years ago

the weblink is broken

#3 Updated by Giovanni Manghi over 9 years ago

I will give another link asap

#4 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Hi, I tested again on trunk the problematic shaped and now it works all fine. So I'm closing this.

Also available in: Atom PDF