Bug report #2275

Layer units and measuring

Added by dr - almost 11 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12335

Description

1. Settings - Project Properties, set layer units to degrees.

2. Try to measure line. Results is in degrees.

3. Settings - Project Properties, set layer units to meters.

4. Try to measure line. Results is in degrees again until clicking right button on mouse.

degrees.gif (9.96 KB) dr -, 2009-12-13 09:29 AM

History

#1 Updated by Marco Hugentobler over 10 years ago

I cannot reproduce this bug. Is it still true?

#2 Updated by dr - over 10 years ago

Yes, it is still true.

#3 Updated by Anne Ghisla over 10 years ago

The unit in the total box changes immediately after hitting OK in Project Properties window, however, the subtitle "Segments (in $unit)" needs a right-click and the start of new measurements to be changed to the new unit. - Debian testing, self-compiled QGIS d4195f3d (SVN r13851).

It's confusing for me that the total is displayed in the new unit and the subtotals are mixed, even if there is no conversion of the raw values. Shall the Measure window be refreshed also from old measurements?

#4 Updated by Paolo Cavallini over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

It should be fixed now. Please check with trunk and reopen if necessary.

Also available in: Atom PDF