Bug report #2261

digitizing when a project is saved with new symbology results in a crash

Added by Paolo Cavallini almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12321

Description

When working with a saved project (see attached) using new, advanced symbology, QGIS consistently crashes at the first click on the canvas during editing operations.

corso.qgs.zip - sample project with new symbology (6.69 KB) Paolo Cavallini, 2009-12-11 12:05 AM

Associated revisions

Revision 06cbd6db
Added by Martin Dobias almost 10 years ago

Fixed snapping to background layers if there's a layer that doesn't exist. Fixes #2261

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 6f23f9e8
Added by Martin Dobias almost 10 years ago

Fixed snapping to background layers if there's a layer that doesn't exist. Fixes #2261

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi almost 10 years ago

confirmed also under linux. It may be a issue related with this particular project file/symbology, as with others doesn't happens.

#2 Updated by Martin Dobias almost 10 years ago

I'm unable to replicate. Could you please attach also the data which leads to crashes?

#3 Updated by Paolo Cavallini almost 10 years ago

Unfortunately not: the project was done by one of my students during a course, on a sample db. If this proves a local problem, we can close it; I posted it just in case it helps discover some underlying problem

#4 Updated by Giovanni Manghi almost 10 years ago

easily replicable for me under linux: open the attached project (it will warn that there is missing data), add polygon, toogle editing, try add a new polygon -> qgis crashes.

#5 Updated by Martin Dobias almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

The crash was actually caused by snapping to a non-existing layer. Nevermind, fixed in 6f23f9e8 (SVN r12516).

Also available in: Atom PDF