Bug report #2258

multiple attribute tables for one layers; many docked attribute tables make layer list unreadable

Added by dr - almost 10 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:12318

Description

1) Docked and undocked attribute table for one layer can be opened many times.
2) If open many docked attribute tables (for one or for many layers), than TOC becomes too narrow and attribute table buttons overlaps.

History

#1 Updated by Jürgen Fischer almost 10 years ago

Is there a problem with having multiple attribute tables for one layer?

#2 Updated by dr - almost 10 years ago

I guess that having multiple attribute tables for one layer is not necessary function. Besides I can't imagine how these tables can allocate within dock window.

#3 Updated by Borys Jurgiel almost 10 years ago

The problem is a risk of data inconsistency if one forgets about them and performs edits in both tables...

#4 Updated by Paolo Cavallini over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

Untrue: the tables are updated on the fly

#5 Updated by dr - over 9 years ago

  • Resolution deleted (invalid)
  • Status changed from Closed to Feedback

#6 Updated by Paolo Cavallini over 9 years ago

See also 1893

#7 Updated by Paolo Cavallini over 9 years ago

I mean #1893

#8 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#9 Updated by Giovanni Manghi almost 8 years ago

  • Assignee deleted (nobody -)
  • Resolution set to duplicate
  • Pull Request or Patch supplied set to No
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Status changed from Feedback to Closed

Duplicate of #1893

Also available in: Atom PDF