Bug report #22075

Map composer: "href" HTML attribute issue in PDF output

Added by Tais Grippa 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.4.4 Regression?:No
Operating System:Linux Mint Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:29888

Description

Hi,
I'm trying to use the href html attribute in a map composer under Qgis 3.4.4-Madeira.
The issue: When using code [1] and exporting my map as .pdf, the text is colorized in blue but impossible to click on it.
When I change to code to [2], with the complete url as a "text", then it works. I provide an output showing this issue.
I don't know it has already been reported and/or still exists in more recent versions.

[1] <a href="https://www.w3schools.com/tags/att_a_href.asp" target="_blank"> Click here to see how to use HREF</a> <br/>
[2] <a href="https://www.w3schools.com/tags/att_a_href.asp" target="_blank"> https://www.w3schools.com/tags/att_a_href.asp&lt;/a> <br/>

Example_href_issue.pdf (8.79 KB) Tais Grippa, 2019-05-14 01:21 PM

History

#1 Updated by Alessandro Pasotti 5 months ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

They are both not clickable to me.

I'm sorry but think this is a won't fix because of how the underlying libraries (QT) export data to PDF.

There is some ongoing work to support geopdf output but I don't know if that will be a game changer for this particular issue.

Also available in: Atom PDF