Bug report #2196

terrain analysis plugin: slope does not work

Added by Paolo Cavallini almost 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12256

Description

When choosing slope from the plugin, nothing is done.

History

#1 Updated by Marco Hugentobler almost 11 years ago

Works for me. Maybe a problem with reading / writing raster files or a processing error?
Could you attach a sample file?

#2 Updated by Paolo Cavallini almost 11 years ago

Tested with several rasters and on several machines (both deb and win xp).
Used to work in the same setting until a few days ago.

#3 Updated by Giovanni Manghi almost 11 years ago

works for me on both linux and windows with qgis/trunk

#4 Updated by Paolo Cavallini almost 11 years ago

Checked again with a fresh comiled qgis, different dtm, different formats, and I still get the same result: nothing is done for slope, correct results for aspect (on the same raster). Only (unrelated?) msg from the terminal:

Warning: Object::connect: No such slot QgisApp::projectChanged( QDomDocument & ) in /home/paolo/build/qgis_unstable/src/app/qgisapp.cpp:1815

#5 Updated by Giovanni Manghi almost 11 years ago

Paolo can you provide me with the data (even privately)? I also tested different dtm and it still works for me.

#6 Updated by Giovanni Manghi almost 11 years ago

Paolo, it works for me (with trunk under ubuntu) with the sample raster you sent me.

#7 Updated by Paolo Cavallini almost 11 years ago

Rebuilding with debug on solves the problem. May be a local compilation issue

#8 Updated by Giovanni Manghi almost 11 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

it seems that after recompiling now it works fine.

Also available in: Atom PDF