Bug report #2174

Crashes when switching field column with "New Symbology"

Added by springmeyer - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12234

Description

1) load shapefile (I used testdata 'polys.shp'
2) Layer Properties, choose "Catagories"
3) Hit "Classify", then "Apply", works so far...
4) Keep Properties open
5) Change the 'Column' from 'Name' to 'Value'
6) hit "Classify"... crash

History

#1 Updated by Giovanni Manghi almost 10 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

There is no such shape in the qgis sample dataset, but I found one in the qgis-mapper svn that seems the one that was used.

I cannot reproduce the problem on both linux and windows using the latest svn code (f2c0df21 (SVN r12308)) on both platforms.

Give it a try again, and then if the problem persist please attach the actual shape is giving you problems. Will reopen if necessary.

Also available in: Atom PDF