Bug report #2173

Crash in python console when renderer changes

Added by springmeyer - almost 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data:

Description

To replicate:

1) Add layer
2) open python console

l = qgis.utils.iface.mapCanvas().layer(0)
print l.isUsingRendererV2()
ren = l.rendererV2()

3) edit symbology of layer with console open
4) type 'print ren' in console again... crash

The object no longer exists and should be returned as None rather than crashing QGIS.

History

#1 Updated by Jürgen Fischer almost 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #777 - the problem are python references to destroyed objects.

Also available in: Atom PDF