Bug report #2172

Crash when classifying with 'graduated' renderer

Added by springmeyer - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12232

Description

To replicate:

1) New project, load polygon shapefile (I used 'polys.shp' from qgis test data
2) Layer Properties, turn on "New Symbology"
3) Choose 'Graduated'
4) Hit classify, crash....

History

#1 Updated by Giovanni Manghi almost 10 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

There is no such shape in the qgis sample dataset, but I found one in the qgis-mapper svn that seems the one that was used.

I cannot reproduce the problem on both linux and windows using the latest svn code (f2c0df21 (SVN r12308)) on both platforms.

Give it a try again, and then if the problem persist please attach the actual shape is giving you problems. Will reopen if necessary.

Also available in: Atom PDF