Bug report #21706

Split Vector Layer only saving geopackage

Added by Avery DeGolyer about 1 year ago. Updated 11 months ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.4.6 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:29522

Description

In qgis ltr 3.4.5 and 3.4.6 on windows the split vector layer algorithm is only saving results as geopackages. I have tried changing the value of DEFAULT_OUTPUT-VECTOR-LAYER-EXT in the advanced options menu but this doesn't seem to change anything with this algorithm. Geopackage is a very nice format, but the devices that I need to send this output to will only accept shape.

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Regression? changed from Yes to No
  • Subject changed from qgis 3.4.5+ on windows Split Vector Layer only saving geopackage to Split Vector Layer only saving geopackage

It is by design that processing now spits outputs in gpkg rather than other formats. This tool has the particularity of needing an output folder, that does not lave any other choice, but for other tools you can select different output formats. Your geopackages can easily be converted to a whatever other format you need, also using tools in the Processing toolbox.

I would say that this is a feature request (for the tools like the "split vector layer" that output to a folder), unless this is already possible in some way other than tinkering with the advanced variables.

#2 Updated by Alexander Bruy 11 months ago

  • Resolution set to wontfix
  • Status changed from Open to Rejected

As Giovanni said this is by desing.

Also available in: Atom PDF