Bug report #21626

crash on open

Added by Jeremy Spurway over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.6.0 Regression?:No
Operating System:opensuse leap 15.0 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:Yes Copied to github as #:29442

Description

Hi,

I've recently re-built my laptop with a new install of opensuse 15.0; I retained my /home/ directory, but masked my previous .qgis2 config folders. I was previously on QGIS2.14.

I've tried installing 2.18, 3.6, and now 3.4.5, but none of them work.

Initially, QGIS loaded, but would crash when I attempted to add a projected vector layer.

Now QGIS crashes before the 'Madeira' splash screen has disappeared, and after it says 'QGIS Ready!'.

I've installed the QGIS debug packages, which seems to stop it dumping the core, but the GUI is unresponsive; and the process is extremely reluctant to

I've added two console logs w/o debug (00) and w/ debug (04).

what more info can I supply?
where do I look for the core dump (I've been executing qgis from ~/ but I don't see any likely files in the folder)?

qgis345_00.log Magnifier - console log (114 KB) Jeremy Spurway, 2019-03-20 01:32 PM

qgis345_04.log Magnifier (133 KB) Jeremy Spurway, 2019-03-20 02:13 PM

qgis360_02.log Magnifier - console log of crashing qgis 3.6.0 lp1502.2 (142 KB) Jeremy Spurway, 2019-03-24 11:10 PM

History

#1 Updated by Jeremy Spurway over 1 year ago

N.B. debug packages 'delay' rather than 'stop' core dump

#2 Updated by Giovanni Manghi over 1 year ago

a packaging issue maybe? who prepared the ones for suse?

#3 Updated by Jeremy Spurway over 1 year ago

And now 3.4.5 QGIS LTR is no longer available from https://download.opensuse.org/repositories/Application:/Geo/, so I can't undertake further tests on the LTR version; the only version available for Opensuse Leap 15.0 appears to be 3.6.0, (qgis-3.6.0-lp150.2.2.x86_64.rpm), which was built today, so I'll try that.

#4 Updated by Jeremy Spurway over 1 year ago

#5 Updated by Jeremy Spurway over 1 year ago

@ Giovanni: the package doesn't have anyone attributed as 'packager'

#6 Updated by Jeremy Spurway over 1 year ago

Now that 3.4.5 is no longer available on opensuse repositories, this bug should be re-named to 'QGIS 3.6.0 crash on open'

#7 Updated by Jürgen Fischer over 1 year ago

  • Affected QGIS version changed from 3.4.5 to 3.6.0
  • Subject changed from QGIS 3.4.5 crash on open to crash on open

Jeremy Spurway wrote:

Now that 3.4.5 is no longer available on opensuse repositories, this bug should be re-named to 'QGIS 3.6.0 crash on open'

No, the version number should not be in the subject at all. ;)

#8 Updated by Hennning Finckenstein over 1 year ago

My environment is openSuse 15.0 and QGIS 3.6.0 too and I have the same problem.
QGIS starts up to the message QGIS is ready and opens the Start-Window.
After that long time nothing happens and the window closes.

My Systemd-Jounal shows:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 63264, resource id: 136314896, major code: 15 (QueryTree), minor code: 0 and
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:334: Unable to assign [undefined] to int

as last entries. Maybe it's an issue with QT and/or Plasma. I'm not an expert with that.

Help is despetately required.

#9 Updated by Hennning Finckenstein over 1 year ago

It' not QT - it's libproj.

Found a workaround:
https://bugzilla.opensuse.org/show_bug.cgi?id=1130269

In short:
remove libproj15, install libproj13 and ignore breaking dependancy

good luck

#10 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Closing as upstream issue?

#11 Updated by Hennning Finckenstein over 1 year ago

I found a workaround but that is not a solution surviving the next update.
What is an upstream issue? I'm new in this forum.
How we can ensure that a final adjustment will be made?

#12 Updated by Cristhian Castro over 1 year ago

Jeremy Spurway wrote:

Hi,

I've recently re-built my laptop with a new install of opensuse 15.0; I retained my /home/ directory, but masked my previous .qgis2 config folders. I was previously on QGIS2.14.

I've tried installing 2.18, 3.6, and now 3.4.5, but none of them work.

Initially, QGIS loaded, but would crash when I attempted to add a projected vector layer.

Now QGIS crashes before the 'Madeira' splash screen has disappeared, and after it says 'QGIS Ready!'.

I've installed the QGIS debug packages, which seems to stop it dumping the core, but the GUI is unresponsive; and the process is extremely reluctant to

I've added two console logs w/o debug (00) and w/ debug (04).

what more info can I supply?
where do I look for the core dump (I've been executing qgis from ~/ but I don't see any likely files in the folder)?

Buenas noches a mi también me sucedió este problema al actualizar mi Qgis 3.6 en Opensuse Leap 15.0, y me pude dar cuenta que después de ejecutar el programa a través de Konsole, este arroja el siguiente error:

src/core/qgsmessagelog.cpp:29 : (logMessage) [1265ms] 2019-03-23T22:55:23 Processing2 Problem with SAGA installation: SAGA was not found or is not correctly installed
src/gui/qgsmapcanvas.cpp:499 : (refresh) [28ms] CANVAS refresh - invalid settings -> nothing to do
src/gui/qgsmapcanvas.cpp:499 : (refresh) [4ms] CANVAS refresh - invalid settings -> nothing to do
src/core/qgsmessagelog.cpp:29 : (logMessage) [57ms] 2019-03-23T22:55:23 Processing1 Invalid algorithm ID for menu: qgis:polygonstolines

Por lo que puedo deducir el problema es el empaquetado que se encuentra disponible en los repositorios......espero que ojala pudieran resolver este problema pronto ya que no puedo esperar hasta que salga una nueva actualización......

Lo que mas me entristece es que Qgis tenga mejor compatibilidad en MS Windows que en su propio sistema de origen (Linux)

#13 Updated by Jeremy Spurway over 1 year ago

https://build.opensuse.org/package/show/Application%3AGeo/saga-gis shows that SAGA build failed; hence it is not available for Leap 15.0, I guess. It won't install from https://software.opensuse.org/package/saga-gis because the repository info is out-of-date; and Leap 15.0 is not available on https://software.opensuse.org//download.html?project=Application%3AGeo&package=saga-gis

I'm not sure this is what is causing the crash, though. SAGA provides optional features...

#14 Updated by Jeremy Spurway over 1 year ago

@Hennning: thanks for your workaround - it enabled me to open a (2.14) project;

it subsequently crashed whilst trying to open a TIFF layer:

...
src/providers/gdal/qgsgdalprovider.cpp:160 : (QgsGdalProvider) [1ms] constructing with uri '/home/jeremy/GIS/data/OS VectorMap District (Raster) NN/data/georefNN/NN60.tif'.
Warning 1: TIFFFetchNormalTag:Incompatible type for "RichTIFFIPTC"; tag ignored
src/providers/gdal/qgsgdalprovider.cpp:2620 : (initIfNeeded) [6ms] GdalDataset opened
qgis: symbol lookup error: /usr/lib64/libgdal.so.20: undefined symbol: GTIFNewEx

#15 Updated by Giovanni Manghi over 1 year ago

What is an upstream issue? I'm new in this forum.
How we can ensure that a final adjustment will be made?

is the problem in QGIS core code, or the problem depends on a dependency on particular platform (i.e. suse)?
If is the latter then is not a QGIS issue, I guess.

#16 Updated by Hennning Finckenstein about 1 year ago

Hi, since the latest Suse-update the problem is solved. In my opinion the issue could be closed.

#17 Updated by Jürgen Fischer about 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

Also available in: Atom PDF