Feature request #2159

Page Setup menu item for Mac os printing

Added by vrgsmm01 - about 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12219

Description

Page Setup menu item must be added in file menu for MacOS printing correctly

bug2159fix.diff Magnifier - Patch generated by SVN in Eclipse (3.91 KB) Charles Timko -, 2010-05-18 10:56 AM

History

#1 Updated by John Tull almost 11 years ago

I would like to second the call to fix this. As things currently stand in OS X, you have to save a composer project as an image, then go to another program to print the file. Currently, qgis defaults to the standard letter size (likely based on locale) on OS X and there is no widget to change the paper format, as in the dialog on linux systems. So on my system, it will go through the render process, but only produce a print file for the first 8.5x11 inches of you print image.

For reference, see:
http://doc.trolltech.com/4.5/qpagesetupdialog.html

#2 Updated by Charles Timko - over 10 years ago

Verify this ticket is identical to this ticket -> #2425|

#3 Updated by John Tull over 10 years ago

Yes, this ticket and #2425 are the same. I would suggest bringing the description from 2425 over here before closing 2425.

#4 Updated by Charles Timko - over 10 years ago

  • Status changed from Open to In Progress

"When you try to print from the composer...if the layout paper is bigger than A4

...print result is out of range.

This problem can be fixed by adding an additional menu idem "page setup" in macos version otherwise can't print layouts in plotter...because page setup doesn't work properly.

In version 0.74 the page setup is working perfectly...because if the composer map paper is different from the printing paper...the "page setup dialog" is appearing asking you to choose the appropriate page and printer for printing!

Now...in current version 1.4 this feature is not present...why???" ~ #2425

Patch ready for this as well.

#5 Updated by John Tull over 10 years ago

I confirmed the patch worked on my trunk build. Good work!

#6 Updated by Jürgen Fischer over 10 years ago

  • Status changed from In Progress to Open

#7 Updated by Marco Hugentobler over 10 years ago

The patch looks good. I didn't realize there is a problem with the page dialog on MacOS.

I have only two minor comments:
- The deletes are missing (or creat objects on the stack)
- Is it intentional that the page setup dialog is modeless (show() instead of exec() ) ?. Because now, the user could open a lot of page setup dialogs at the same time.

Regards,
Marco

#8 Updated by John Tull over 10 years ago

Hi Marco. This patch was assigned to you when submitted, so it was assumed that you knew. Unfortunately, there are numerous others assigned to you related to print composer, so perhaps a review of what is open is in order.

Regarding the modeless setting, the page setup dialog is exposed as a sheet rather than a separate dialog, so I don't think it is possible to have more than one at a time. I could not get it to do so anyway. I have noticed an occasional disappearing print dialog, but I do not know if this is in any way related.

#9 Updated by Marco Hugentobler over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Applied in 63c6950c (SVN r13546) with the mentioned modifications.
Thanks ctimko!

Also available in: Atom PDF