Bug report #21439

Split Tool: Self-intersecting line is also split at every intersection

Added by Bernd Vogelgesang about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:3.4.4 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:29256

Description

When splitting a line that is self-intersecting (e.g. a GPS-track), with the split tool from the advanced digitizing toolbox, the line is split into multiple parts at each intersection instead of only two parts at the chosen spot.

As I can see no benefit from this behaviour, I regard it as a bug.

Tested with 3.4.4 on Linux Mint, with a Shapefile and a SpatiaLite-File


Related issues

Duplicates QGIS Application - Bug report #4087: Split Features tool: lines are split also at every self-i... Open 2011-07-14

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Regression? changed from Yes to No
  • Status changed from Open to Feedback

I think this is a duplicate of a lOOOng standing issue: https://issues.qgis.org/issues/4087 can you confirm?

#2 Updated by Bernd Vogelgesang about 1 year ago

I can confirm that this is a duplicate of this loooong standing issue.

I have to admit, this is a rare use case. But nevertheless.

#3 Updated by Giovanni Manghi about 1 year ago

  • Duplicates Bug report #4087: Split Features tool: lines are split also at every self-intersection added

#4 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF