Bug report #21414

Layouts/Reports Filtered Attribute Table Filtering Broken

Added by Spencer Gardner over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.4.5 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29231

Description

Attribute table objects do not populate with data when added to a Layout or Report and filtered to an Atlas object. When the table is added the column headings are visible but no rows are displayed. Appears to be a regression--I had this working in 3.4.2.

Steps to reproduce:
1. Create a new map document
2. Add a layer with at least one feature to the map
3. Add a non-geometry table to the map with an attribute matching an attribute in the layer from #2
3. Create a new Layout
4. Add an attribute table to the Layout
5. Activate the Atlas
6. Filter the attribute table with an expression like the following (modified for your dataset:
"my_attribute" = attribute(@atlas_feature,'my_attribute')

What should happen: the table is displayed with attribute data from the current Atlas feature
What happens: the table columns are displayed but no feature data is shown

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Priority changed from Normal to High

#2 Updated by Spencer Gardner over 1 year ago

It appears this was due to a missed backport on a bugfix to the master branch.
See: https://github.com/qgis/QGIS/pull/9306

#3 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF