Bug report #21387

Unavailable layers because of a moved folder

Added by Edward H 11 months ago. Updated 10 months ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Vectors
Affected QGIS version:3.7(master) Regression?:No
Operating System:Any Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29204

Description

Hi,

I have an issue in QGIS 3.6 (Windows 10 / 64 bits) with the replacement or the renaming a folder/layer.

If a folder or a layer is moved/renamed, the (new) "file requester" appears (cf unavailable 1.jpeg) and after browsing the new sources of files (cf unavailable 2.jpeg) all the files recovered appears on the top of the layers area, checked (because it's my default settings) and not in the right group and un-checked (cf unavailable 3.jpeg)

thanks if anyone can look at this.

unavailable 1.JPG (450 KB) Edward H, 2019-02-26 09:53 AM

unavailable 2.JPG (446 KB) Edward H, 2019-02-26 09:53 AM

unavailable 3.JPG (662 KB) Edward H, 2019-02-26 09:53 AM

test QGIS issue folder.zip (25.3 KB) Edward H, 2019-02-26 02:11 PM

Associated revisions

Revision 5bc2183d
Added by Alessandro Pasotti 10 months ago

Keep group and checked state when handling bad layers

Fixes #21387 - Unavailable layers because of a moved folder

Revision 452d4b26
Added by Alessandro Pasotti 10 months ago

Keep group and checked state when handling bad layers

Fixes #21387 - Unavailable layers because of a moved folder

Revision af972502
Added by Alessandro Pasotti 10 months ago

Keep group and checked state when handling bad layers

Fixes #21387 - Unavailable layers because of a moved folder

History

#1 Updated by Alessandro Pasotti 11 months ago

  • Status changed from Open to Feedback
  • Assignee set to Alessandro Pasotti

It would be very helpful if you could attach a zip file with a minimal project and data to reproduce the issue.

#2 Updated by Edward H 11 months ago

Thank's for the prompt answer and I attach a zip file like you asked me

steps to reproduce this issue :

- open the project in the zip file
- have a look at the distribution of layers into the groups
- quit the project
- rename one of the folders
- re-open the project
- re-assign the correct name of the folder for each unavailable layers
- this layers move on the top and they are checked by default and a group is empty

#3 Updated by Alessandro Pasotti 11 months ago

Thank you for sharing the project and data.

So, basically, the issue is that the original layer's group and checked/unchecked state are not preserved when handling bad layers from the dialog?

#4 Updated by Edward H 11 months ago

Yes exactly and also found at the top of the layer's panel
And in my case, I have a lot of layer's group and folders change names regularly in Windows...

#5 Updated by Alessandro Pasotti 11 months ago

  • Category changed from Unknown to Vectors
  • Status changed from Feedback to Open

#6 Updated by Giovanni Manghi 11 months ago

  • Status changed from Open to Feedback

Is this really a regression?

#7 Updated by Edward H 11 months ago

This is certainly not a regression regarding the development of qgis functionalities (and for bug tracking) but in terms of user experience it's pretty annoying to lose its organization of layers.
By the way, it works fine on the LTR version :)

#8 Updated by Giovanni Manghi 11 months ago

  • Priority changed from High to Normal
  • Regression? changed from Yes to No

#9 Updated by Alessandro Pasotti 10 months ago

  • Status changed from Feedback to Open

#10 Updated by Alessandro Pasotti 10 months ago

  • Resolution set to fixed/implemented
  • Status changed from Open to In Progress
  • Affected QGIS version changed from 3.6.0 to 3.7(master)
  • Operating System changed from Windows 10 / 64 bits to Any
  • Pull Request or Patch supplied changed from No to Yes

#11 Updated by Alessandro Pasotti 10 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF