Bug report #21367

QGIS 3.6.0 _ Grass Tools 7.6 tools not found in processing tool box

Added by Brad Kanther over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:3.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:29184

Description

It seems in 3.9 the grass tools can not be found

Where can the Grass 7 tools path be specified 3.6?

grasstools.jpg (31.5 KB) Brad Kanther, 2019-02-25 05:10 AM

grassspecify.jpg (53 KB) Brad Kanther, 2019-02-25 05:10 AM

grasspliugin.png (44.5 KB) Brad Kanther, 2019-03-05 05:43 AM

History

#1 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

#2 Updated by Jürgen Fischer over 1 year ago

Did you start QGIS with the "QGIS Desktop 3.6.0 with GRASS 7.6.0" link?

#3 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Closed to Feedback

#4 Updated by Cong Ning over 1 year ago

QGIS can't define the path of grass moudle after version 3.4.
I think the problem is a bug. But I try to start QGIS with the "QGIS Desktop 3.6.0 with GRASS 7.6.0" link.
However, I use Grass algorithm in process tools to split some lines. And I get the warning to say the grass stop work. But finally I get the output layer.

#5 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Closed

#6 Updated by Brad Kanther over 1 year ago

As a final follow up here. This installation was via OSGEO4W installer and the "GrassPlugin" was not listed as a necessary dependancy of QGIS 3.6 installing. Therefore a shortcut "QGIS 3.6 with GRASS 7.0.6" was not available to the user.

Ticked it on now it works.

Also available in: Atom PDF