Bug report #21214

QGIS 3.4 asks "Do you want to save the current project?" **immediately** after program finishs the starting process.

Added by sand thorn 12 months ago. Updated 11 months ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:29032

Description

Affected Platform:
Windows 10 64-bit v1809
QGIS 3.4.4 64-bit

The v3.5 weekly is also affected.

Perhaps my very own configuration file is messed up? Any suggestions?

History

#1 Updated by Regis Haubourg 12 months ago

  • Priority changed from Normal to High
  • Affected QGIS version changed from 3.4.4 to 3.5(master)
  • Regression? changed from No to Yes

Hi confirmed here on linux, with 3.4 or master as well. Opening an empty QGIS session asks to save the current projet. Really annoying.

#2 Updated by Paul Blottiere 11 months ago

Hi @sand thorn,

In the case of @Regis Haubourg, the issue was due to the mask plugin. Can you run QGIS with the --noplugins option?

#3 Updated by Paul Blottiere 11 months ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi 11 months ago

Paul Blottiere wrote:

Hi @sand thorn,

In the case of @Regis Haubourg, the issue was due to the mask plugin. Can you run QGIS with the --noplugins option?

or also try with a new profile.

#5 Updated by Regis Haubourg 11 months ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

Ok, with a fresh profile I don't have the issue. Let's close that and raise upstream the issue.

#6 Updated by Regis Haubourg 11 months ago

A patch is coming upstream in the plugin : https://github.com/aeag/mask/issues/72

#7 Updated by sand thorn 11 months ago

For me, "Mask" plugin is in "Not Installed" category.
I never enable this "Mask" plugin.

With "--noplugins" still reproduces this bug.

#8 Updated by Sylvain POULAIN 11 months ago

Semi-Automatic Classification Plugin generates same bug

https://github.com/semiautomaticgit/SemiAutomaticClassificationPlugin/issues/53

Also available in: Atom PDF