Bug report #21097

Opening shapefiles in ZIP gives Invalid Datasource

Added by Marijn Biekart almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.4.4 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:28915

Description

Hello,

In the latest version of Qgis it is no longer possible to open a zipped shapefile. I get the "(filename) is an invalid datasource" error warning.

- The issue is not present in 3.2
- I noticed this using drag-and-drop but the Layer-Add layer-Add vector layer route does not work either
- The issue is both with zipfiles on a NAS and local C drive.
- the issue seems independent on the actual content of the shapefile

I will try this again at my home installation.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

please attach sample data.

#2 Updated by Alessandro Pasotti almost 2 years ago

Sample data doesn't matter I can reproduce it with any zip file on windows (but only through the data source manager: the browser is fine).

#3 Updated by Alessandro Pasotti almost 2 years ago

I just tried a current master build on windows and I could not reproduce, while with a master build of two weeks ago I still can, can you please try the latest master build and check if the problem is still there?

#4 Updated by Marijn Biekart almost 2 years ago

Just tried it at home, no issues there. Probably local issue? I'll test more monday.

#5 Updated by Alessandro Pasotti almost 2 years ago

Please make sure you test the three scenarios:

1 - drag and drop into the canvas
2 - open from the QGIS browser panel
3 - open from the data source manager dialog

#6 Updated by Marijn Biekart over 1 year ago

Tried on a clean installation, problem seems to have resolved itself. could someone close the issue for now?

#7 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF