Bug report #21091

Error opening network KML page: Range downloading not supported by this server!

Added by Robert Richardson about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Data Provider/OGR
Affected QGIS version:3.5(master) Regression?:No
Operating System:Any Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:28909

Description

Trying to connect to http://www.fire.tas.gov.au/Show?pageId=boundaryKml2 gives "Invalid Data Source /vsicurl/http://www.fire.tas.gov.au/Show?pageId=boundaryKml2 is not a valid or recognised data source".

This connection worked in QGIS 2.18.14 and 3.4.2.

Network_KML_bug.pdf - Screen print (431 KB) Robert Richardson, 2019-01-25 05:05 AM

Associated revisions

Revision cf0d45e5
Added by Alessandro Pasotti about 1 year ago

OGR: add a download option to the protocol data source

Fixes #21091

The issue was due to the /vsicurl/ not
being able to open a streaming endpoint.

“Things are not always what they seem; the first appearance
deceives many; [...]”

― Phaedrus

History

#1 Updated by Alessandro Pasotti about 1 year ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti about 1 year ago

  • Operating System changed from Windows 10 to Any
  • Status changed from Open to Feedback
  • Affected QGIS version changed from 3.4.4 to 3.5(master)

How do you know about the extra char? I think that the issue is quite different, this is what I get from the logs:

Cannot open /vsicurl/http://www.fire.tas.gov.au/Show?pageId=boundaryKml2.
OGR3 error 1: Range downloading not supported by this server!

the download happens through GDAL which in turn (I think) uses "curl" library, curl assumes it's a streaming capable server which apparently is not.

#3 Updated by Alessandro Pasotti about 1 year ago

  • Pull Request or Patch supplied changed from No to Yes
  • Resolution set to fixed/implemented
  • Status changed from Feedback to In Progress
  • Category changed from Vectors to Data Provider/OGR
  • Subject changed from Opening network KML page adds extra characters to URL so page is not found to Error opening network KML page: Range downloading not supported by this server!

#4 Updated by Robert Richardson about 1 year ago

The extra characters show in the screen dump. Bug report 20925 is about be able to successfully accessing the same file in 3.4.3 but seeking an F5 refresh. Presumably 3.4.3 doesn't require a streaming capable server.

#5 Updated by Alessandro Pasotti about 1 year ago

If you mean "vsicurl" that's not the issue, it is added by the OGR provider and it's correct.

The problem here is that OGR cannot open that online file without downloading it first, but there is no (easy) way to handle that directly from the provider.
So, my idea in the PR was to offer an option to download the file before opening and that works correctly but my approach has some drawbacks (see the PR for the complete discussion).

#6 Updated by Robert Richardson about 1 year ago

My apologies, I didn't understand the full implications of the PR. The proposed solution should work well for me and may also help with the user who submitted #20925. Thank you.

#7 Updated by Alessandro Pasotti about 1 year ago

No need to apologize, this is not really a bug because it works fine as long as you choose "File" instead of "Protocol", but there is not an easy way to explain when "File" has to be preferred to "Protocol", I guess that my latest proposal would give the best user experience: if the protocol option fails, offert the opportunity to immediately try the "File" one.

Btw, the immediate workaround for you is to choose "File" and paste your URL there.

And yes, a simple thing became a lot of work but that's not your fault :)

We definitely need more donors and contributors if we want to keep making QGIS better and better!

#8 Updated by Alessandro Pasotti about 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF