Bug report #21073

QGIS3 3.4.4 cannot be opened because of a problem - Crash on launch

Added by Philip Kampf over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:mac_os_specific
Affected QGIS version:3.4.4 Regression?:No
Operating System:OS 10.14.3 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:28891

Description

Just downloaded QGIS 3.4.4, running OS 10.14.3, cannot launch newly installed version. Prior to downloading, had uninstalled QGIS/GDAL following instructions on saved readme file and using cleanmymac to uninstall application itself.

Immediately goes to crash report, attached text file below. Let me know if I can provide anything further.

qgis3_4_4_crash_report_20190122.rtf (7.21 KB) Philip Kampf, 2019-01-22 09:47 PM

History

#1 Updated by Philip Kampf over 1 year ago

Have deleted all contents in Users/User/Library⁩/⁨Application Support⁩/QGIS, but this does not work as solution as in previous releases

Found similar issue, not sure how to implement in this release -

https://github.com/lutraconsulting/qgis-mac-packager/issues/2

#2 Updated by Giovanni Manghi over 1 year ago

  • Category changed from Unknown to mac_os_specific
  • Priority changed from Normal to High

#3 Updated by Saber Razmjooei over 1 year ago

Have you tried to use packages from here:
https://lutraconsulting.github.io/qgis-mac-packager/

#4 Updated by Philip Kampf over 1 year ago

Saber Razmjooei wrote:

Have you tried to use packages from here:
https://lutraconsulting.github.io/qgis-mac-packager/

I have not, thank you, I'll give it a shot.

#5 Updated by Philip Kampf over 1 year ago

Saber Razmjooei wrote:

Have you tried to use packages from here:
https://lutraconsulting.github.io/qgis-mac-packager/

The 3.4.4 package from lutra consulting worked, thank you Saber

#6 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to Closed
  • Resolution set to invalid

#7 Updated by Saber Razmjooei over 1 year ago

@Elpaso, not sure my work-around addressed the issue :)

The official QGIS package for macOS still has the issue. There are some suggestions on the mailing list as a better solution.

Also available in: Atom PDF