Bug report #21068

Button positions in Database styles manager dialog

Added by Alexander Barth about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:GUI
Affected QGIS version:3.5(master) Regression?:No
Operating System:Any Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28886

Description

In the "Database styles manager" dialog that opens when loading a style. The Buttons "Abbruch" (Cancel) and "Stil laden" (load style) are placed in the wrong order when compared to the rest of QGIS and Windows in general.

Not a huge issue, but it can be annoying when loading a couple of styles, because the open file dialog where you select your .qml file has the "OK" button on the left side.

Associated revisions

Revision 90a9852b
Added by Alessandro Pasotti about 1 year ago

Fix button order in DB styles dialog and add GPKG delete support

Fixes #21068

Revision 67b5b676
Added by Alessandro Pasotti about 1 year ago

Fix button order in DB styles dialog and add GPKG delete support

Fixes #21068

(cherry picked from commit 90a9852b694acc1aa1a8e84c07efd59b4b6d7d81)

History

#1 Updated by Alessandro Pasotti about 1 year ago

  • Affected QGIS version changed from 3.4.4 to 3.5(master)
  • Operating System changed from Windows 7 to Any
  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti about 1 year ago

  • Status changed from Open to In Progress
  • Pull Request or Patch supplied changed from No to Yes

PR https://github.com/qgis/QGIS/pull/8971

Now the button order is delegated to Qt (OS-dependant): http://doc.qt.io/qt-5/qdialogbuttonbox.html

Also added delete style capabilities for GPKG.

#3 Updated by Alessandro Pasotti about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF