Bug report #21033

Wrong label placement when rotating projected canvas

Added by Klas Karlsson almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:3.4.3 Regression?:No
Operating System:Linux Ubuntu 18.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28852

Description

When I rotate the canvas window any labels in the map will not follow.
It's not stationary! It seems more like the scaling is really off, as well as the general placement.

A link to a video showing the issue:
https://youtu.be/pyb_XzCjACo

Note that it seems to work ok in this case if I keep the data un-projected in wgs-84.

Problem occurs also when using the coordinate field "world" vector layer, so no external data needed to replicate.

History

#1 Updated by Nyall Dawson over 1 year ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

DUplicate of #16897

Also available in: Atom PDF