Bug report #21011

raster calculator in processing does not work with Aspect raster

Added by Janneke van Dijk almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Processing/QGIS
Affected QGIS version:3.4.3 Regression?:No
Operating System:Windows 10 - 64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:28830

Description

Using the raster calculator in processing, using a simple expression (for example "[email protected]" > 0) results in an invalid output raster. The same expression with the same input works as expected using the raster calculator under Raster.

To reproduce:
1. Processing>raster terrain analysis>aspect, use srtm_41_19.tif for input, leave the rest default (this successfully creates aspect)
2. Processing>raster analysis>raster calculator, select the created aspect layer for input, use eg "[email protected]" > 0
Result:
output file seems invalid, under information from provider is shows
STATISTICS_VALID_PERCENT=0
AREA_OR_POINT=Area

srtm_41_19.tif (1.06 MB) Janneke van Dijk, 2019-01-16 01:53 PM

History

#1 Updated by Luigi Pirelli almost 2 years ago

thank you for the detailed issue report

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee changed from Luigi Pirelli to Alessandro Pasotti

#3 Updated by Alessandro Pasotti almost 2 years ago

  • Resolution set to worksforme
  • Status changed from Open to Feedback

I cannot reproduce on master, can you try on latest master?

Btw, some steps are missing between 1 and 2: unless you select "Reference layers" (or set all parameters) the algorithm a point 2 will fail.

#4 Updated by Janneke van Dijk almost 2 years ago

Indeed, downloaded the nightly on Windows and now it works as expected...I guess it is advisable to test potential bugs on master before submitting a bug report :-). Glad it works!

#5 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF