Bug report #20927

QGIS Server: WFS issue using the EXP_FILTER parameter

Added by Geo Dev almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:QGIS Server
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28746

Description

The EXP_FILTER parameter is evaluated only querying the layer fields with the basic operators (">", "<", "=", "LIKE", etc.)
The filter doesn't work using QGIS expressions.

Examples of WFS requests where the expressions are evaluated:

Examples of WFS requests where the expressions are NOT evaluated:

Tested with QGIS 3.4.3 and QGIS 3.5(master).
The issue occurs both with WFS 1.0.0 and WFS 1.1.0.

It's a regression since the same requests on the same projects/layers published with QGIS Server 2.18 work as expected.

Associated revisions

Revision 9b7e1912
Added by Alessandro Pasotti over 1 year ago

Add tests for WFS GetFeature EXP_FILTER

Fixes #20927 - QGIS Server: WFS issue using the EXP_FILTER parameter

History

#1 Updated by Alessandro Pasotti over 1 year ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti over 1 year ago

  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#3 Updated by Alessandro Pasotti over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF