Bug report #20889

Bug regarding SVG symbols base64 encoding

Added by Man Andman almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Symbology
Affected QGIS version:3.4.3 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:28708

Description

There is an issue regarding "complex SVG" depiction. As you see in the GIF (► https://gifyu.com/image/w9Ep) when I embed "monuments SVGs" and then clicked on the base64 code it disappears. But in case of "simple SVGs" the issue is not actual. The same happens when I link base64 code from a layer data table, they do not appear on the map (► https://gifyu.com/image/wESr). So at the moment the embed function is unusable for "complex SVGs".

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

Please test on current master - I believe this is already fixed

#2 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF