Bug report #20812

Edit features in place - fix geometries not working

Added by Andy Whyte almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Processing/Core
Affected QGIS version:3.5(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28631

Description

When using the edit features in place function with fix geometries it does not seem to work.

I tested on the same data set with and without the "in place" function and it worked without.

Please see Gif

Edit in place - fix geometries.gif (1.14 MB) Andy Whyte, 2018-12-14 04:08 PM

NHS_CCG_Boundaries.shp (753 KB) Andy Whyte, 2018-12-17 09:34 AM

Test project.qgz (5.47 KB) Andy Whyte, 2018-12-17 09:34 AM

NHS_CCG_Boundaries.prj (427 Bytes) Andy Whyte, 2018-12-21 11:08 AM

NHS_CCG_Boundaries.dbf (64.2 KB) Andy Whyte, 2018-12-21 11:08 AM

NHS_CCG_Boundaries.shx (1.75 KB) Andy Whyte, 2018-12-21 11:09 AM

Associated revisions

Revision f4d7506e
Added by Alessandro Pasotti almost 2 years ago

Processing in-place do not check validity when fixing geometries

Fixes #20812

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti almost 2 years ago

Would you please add a test project and data? That would speed up the bug fixing process a lot.

#3 Updated by Andy Whyte almost 2 years ago

#4 Updated by Alessandro Pasotti almost 2 years ago

Thanks for attaching data: I'll have a look ASAP.

#5 Updated by Alessandro Pasotti almost 2 years ago

.SHP is not enough for shapefile data, you need to attach all the other files.

#6 Updated by Andy Whyte almost 2 years ago

Apologies

#8 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

Your problem is probably caused by a processing setting, please check under

Settings -> Processing -> General -> Invalid features filtering => Do not filter (better performances)

Obviously that is the only value that makes sense for this algorithm or the invalid features will not even get passed in.

#10 Updated by Alessandro Pasotti almost 2 years ago

  • Affected QGIS version changed from 3.4.2 to 3.5(master)
  • Operating System deleted (Windows 10)

#11 Updated by Andy Whyte almost 2 years ago

Thanks for your help

#12 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Feedback to In Progress

Thank you for filing this issue, it was indeed a bug: the setting should be ignored for those algorithms that fix broken geometries.

#13 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF